Insights data refresh delays

Incident Report for NewStore Inc

Resolved

We have implemented a fix and the Insights data in NOM and in the Associate App Sales dashboard is getting updated on the regular frequency.
Posted Jan 20, 2026 - 19:38 UTC

Identified

We have refreshed the data and are continuing to work on the mitigation of the update delays.
Further delays will be possible, but we are working to keep them to a minimum.
Posted Jan 20, 2026 - 19:14 UTC

Investigating

We are currently experiencing slowness in data update for NewStore Insights in NOM and in the Sales Dashboard in the Associate App
Posted Jan 20, 2026 - 18:39 UTC
This incident affected: Business Areas (Insights).