Order routing delays

Incident Report for NewStore Inc

Resolved

The issue has been resolved and all residual delays have dissipated.
Posted Jul 09, 2026 - 22:26 UTC

Monitoring

Right now all delays have been resolved. We are monitoring the situation.
Posted Jul 09, 2026 - 21:53 UTC

Update

We have implemented a mitigation and are seeing a reduction in routing delays.
Posted Jul 09, 2026 - 21:46 UTC

Identified

We have identified the cause of the delay and are working on its mitigation
Posted Jul 09, 2026 - 21:25 UTC

Investigating

We are currently investigating a delay in order routing and will update here once we have more information
Posted Jul 09, 2026 - 21:17 UTC
This incident affected: Business Areas (Routing).